240v heated bed wiring - Thoughts wanted


#1

Excuse my dodgy pic, but this is my current thinking for my 240v heated bed.

  • I want to keep all 240 connections (SSR, Heated bed) inside a sealed box.
  • I was planning on using an NC termostat like this: https://images-na.ssl-images-amazon.com/images/I/41IVbnN2bAL.SY300.jpg but I don’t like having those 240v spade terminals out in the open.
  • I don’t like having to run a whole other wire out and back for the thermal fuses, but I don’t want to cut into the heated bed wires (it is CE certified) and I don’t want any joins out in the open.
  • Might be worth switching the fused lead onto the active after the SSR?
  • I’ll probably put a switched/fused IEC plug as the power into the SSR box https://www.jaycar.com.au/iec-fuse-chassis-male-power-plug-with-switch/p/PP4003

Anyway - thoughts/comments/ideas are welcome. I’ll get my bro in law (sparky) to check it over as well.


#2

Hi @Squid. I have used the NC thermostat for my 240VAC heated bed and it is bolted to the aluminum build plate. Your circuit diagram shows the thermal fuses in the Neutral line and this is not really good practise as all switching components should be in the live connection. If your heater develops an earth fault then this could bypass the thermal switches and you would loose your thermal protection. It would be best if your isolation switch was in the live connection before the SSR.


#3

If you follow the link you can see pictures of my set-up:
http://community.reprapwilson3d.com/t/redesigning-the-y-bed/888


#4

That looks really good :slight_smile: basically what I had settled on after talking to my uncle.

Are you using PID or bang bang? Do you have a temperature graph of it running?


#5

@squid I am using PID but I had to change some settings to get autotune to work. I haven’t got any temperature graphs and at the moment the printer is down for maintenance. When it is back in action I will post some graphs.


#6

Did you have to slow down the PWM at all? What other settings did you need to change?

Cool, I’ll be keen to see when you get it back up and running… if you beat me to it!


#7

As you will have wires moving again and again etc and close proximity to touchy parts. I recommend you use a GFI with it, to ensure safety. And use a resistor between the machine and line side and ground, to ensure you don’t dump huge amps through the connection. The GFI should trip around 0.01 amps of current so you don’t need to much less than a 22k resistor.

Lastly you will likely want to use dual SSR or an SSR that will handle both sides of your mains since each side is high relative to neutral and ground. It will make sure power is completely free.

Devices like your main AC usually use an electromechanical contactor aka relay to make and break this power connections.


#8

Got the new bed installed, first run after a PID tune:

Close up: