Firmware problem


#1

Hi, I’m not new to 3d printing, but firmware has me stumped. I built a RS version about a year ago and life took over and it was set aside. Now I have time to get back to it and need to load the firmware into arduino. If I use the config h file that is on github I get an error that “NUM_AXIS was not declared in this scope”. I dont have the smart controller installed yet until after I get the machine running, but that should not matter for everything else. Can anyone tell me why I am getting this error? I am using arduino 1.6.7 if that makes a difference.


#2

Could you send the complete error log. NUM_AXIS is used at a lot of places in the firmware and it’s a bit hard to pin point the issue.

You might be interested in getting Marlin-RC version instead of Mjrice build for your Wilson RS as it doesn’t have the added code that is needed for Wilson 2 (rack and pinion Z probe, etc…)

Here’s the “Classic” Marlin-RC firmware : https://github.com/MarlinFirmware/Marlin/tree/RC

You should check Mjrice Wilson TS original build video for the configuration setup.

Hope this help.


#3

Thanks for the reply, I downloaded the most recent Marlin and spent a few hours researching and tweaking config h to get things working right. I did watch the video and was surprised to see how close my numbers were with the video. It was a pain, but I guess I can do it if I have to.
All is working perfect now.


#4

Has anyone ever designed a print cooler to work with this machine?


#5

https://github.com/mjrice/wilson/blob/master/stl/extruder/FAN-DUCT.stl should work fine if you have the direct drive extruder.


#6

Thanks andreq, I dont know how I missed that. The printer is working great, but I work a lot in abs and petg and the only way for me to get bridges right is with cooling. :slight_smile:


#7

Do you have good success with cooling with ABS. I’ve transformed my cooling fan into a hotend cooling duct as I didn’t like the result of the fan blowing on the extruded plastic. Was I doing something wrong?


#8

I have had great success with abs since I started using cooling. I have 2 ecksbot machines, I bought the first one as a kit and built the second from scratch. The cooling fan I use on those machines is directed close to the hot end, but blowing across the print surface http://www.thingiverse.com/thing:91128 . This fan doesn’t blow on the hot end, but across the part below it and I have excellent luck with bridges up to about 1-1/2 inches across with little to no sagging. I hope I can get the same results with this machine. The ecksbot has a .45 hot end and I built this one with a .35 hot end. Time will tell, but I think where the air hits makes a huge difference.