Firmware update messed my interaction and display


#1

After I decided to update the firmware with using a ramps 14 board. My desplay only shows squares and is not interactive. I could reily use help. Here is how my display looks.


#2

I have exactly the same issue :frowning:


#3

what version of marlin are you running? can you post your configuration.h file?


#4

I was able to figure out my problem with my display and Interaction. The new issue I’m having is my auto level is not functioning properly. I could use some help on that matter, and I will share a configuration.h file for anyone to look at solving the issue. Please keep in mind that I’m not using a PICA board. Instead, I’m using a ramps 14 board.


#5


#6

I’m pretty sure the default firmware is configured for PICA, re-check that you have ramps 1.4 defined because afaik they have different pin layouts.


#7

… as it is I can’t see the rest of the file… you have only 3/4 of it here and in this format it’s a little hard to read.

If you put the complete Config.h file zipped up somewhere on the web to download that would make it easier…


#8

I already fixed to interactivity issue and got my RepRap Willson 2 back in order. The only problem I am having now is that every time I set the temperature to print ABS and the printer will set itself back to 210 C for the hot end and 70C for the heat bed. As of now, I am not at my place, but when I’m back at my place sometime Monday night, I will upload a compressed configuration.h file or the entire Marlin firmware. Any help or suggestions will be highly appreciative.