PID Autotuning Help


#1

I have recently upgraded the hotend from the E3D lite6 to the V6 full and I’m having trouble running PID Autotuning. I tried running the M303 E0 S200 C8 command but nothing happens. I ran this from a gcode file on the SD card. Is this the proper way to run Autotuning?


#2

You need to connect to the printer via USB cable and use any slicer that has a command line to manually enter Gcode commands.

I personally use Pronterface http://www.pronterface.com/ I find it nice for doing this sort of thing and manually testing printer axis movements and heating up hotend and bed.

This is not a bad tutorial showing tune through to editing config file. He is using Repetier but it is the same I just like the easy layout of Pronterface


#3

Thanks ant0ny

That worked great. I tried the machine interface in Simplify3d first but then I found I liked pronterface better.


#4

Yeah no probs… I find Pronterface is my “go to” software when I am sorting out printer issues, it always works.


#5

I had built a simple gcode file for this, that I can run from my card if needed.

;Sliced at: Sun 28-08-2016 22:56:43
;Basic settings: Layer height: 0.24 Walls: 1.5 Fill: 30
;Print time: #P_TIME#
;Filament used: #F_AMNT#m #F_WGHT#g
G21                          ;metric values
M107                         ;start with the fan off
G28                          ;home
;Put tuning message on LCD screen
M117 Tuning hotend...
M303 S200 C8 U1
M117 Tuning heatbed...
M303 E-1 S60 C8 U1
M500                         ;save to EEPROM
;End GCode
M104 S0                      ;extruder heater off
M140 S0                      ;heated bed heater off (if you have it)
G91                          ;relative positioning
G1 E-1 F300                  ;retract the filament a bit before lifting the nozzle, to release some of the pressure
G1 Z+0.5 E-5 X-20 Y-20 F6000 ;move Z up a bit and retract filament even more
G1 X0 Y100
M84                          ;steppers off
G90                          ;absolute positioning