Smart Full Graphic Not working on 12v


#1

Hi all

I am new to building the printer from scratch and still waiting on a few parts(bearings and belts). I got the Mega with ramps1.4 and Drv8825 drivers with the 12864 Full graphic display from china.

With a steep learning curve I managed to install marlin (Marty’s version) on the board.

When the mega is connected via the USB with display it all seems to be working fine I can see the menus and click through them.

When I disconnect and only run from the 12v power supply the display only shows a blank display but is blue back-lit. I can not see anything but this not the case if running off the usb.

Just some notes I have not connected any end-stops, motors or sensors to the ramps1.4 yet as I was just testing still.

Thanks in advance


#2

have you tried fiddling with the pot on the screen board on the lower left? sometimes the cheap mega boards have really poor voltage regulation and usb connected/disconnected needs the screen adjusted to get it visible.


#3

I have and it either stays all whited out or goes plane blue No text visable.


#4

Hi @BigAnt

These are notes from the Ramps1.4 Wiki:

Without D1 installed, or when the 12VIN is not connected, the Arduino gets its power from USB. If you want your kit powered without USB connected you need to solder in D1 OR connect VCC to your PSU.

Evidently some boards are shipped without D1 fitted. Here is the section of the Ramps1.4 schematic that shows D1:

And here is where D1 is located on the PCB:

I hope this helps


#5

Thanks @dtbee the diode is installed on the ramps I got. Not sure where the VCC must be connected?
When I turn on the 12v supply to the ramps the Fan used to cool the boards does come on.


#6

Here is a pic to show what happens

Usb Only


#7

I think it’s working fine, you have to fine tune the contrast to see anything on the 12v powered one.

Sadly most of those come with badly set contrast potentiometer, which give you nothing on screen or full blow screen like that.

If it’s anything like mine, it’s a little metal potentiometer…under the screen.
I had to use a tiny screwdriver and lot of fingering skill (:open_mouth:) to get it to move.

Be careful not to short anything.

edit : Here’s a thread about that : http://forums.reprap.org/read.php?13,448609


#8

Thanks @AndreQ I have tried adjusting the Pot even with the smallest movements and its stays 95% white the last 5% goes flat blue.
This tells me the pot is working, I also know its working because when connected via USB power it does adjust nicely up and down.
I did add a 220ohm resistor to the 1 display board but it didnt make a difference. I can try to up the resitance but not sure its the actual problem I am having.

I do also have 3 of the displays and have swopped then in and out while testing.

Is there settings that must be changed in the marlin firmware that allows 12v use? Like I said this is my first even time playing with firmware and code stuff.

I tried to attached a video to show what happens but not allowed.


#9

Not that I’m aware of. If you swapped the screen and still had the issue, surely there’s something shady happening. Did you swap the cables too? Maybe there’s something there.

I remember my screen contrast pot was sensitive as **** and I had to dial it quite precisely, but again, if you swapped the screen, it can’t be that :worried:

I’ll keep digging for more info.

Edit: Got another arduino? Some random youtube video said the 5v regulator was bad on their arduino and it couldn’t initialize the LCD properly due to that.


#10

Yup swapped cables and the connector PCB adapters.

Appreciate any help.

FYI I tried 200 440 660 and 1k Ohm resistors now just to make sure.


#11

Check the ouput voltage after the Arduino regulator if you can, should be close to 5v.
That’s the “only difference” between using USB and 12v.


#12

Nope I got 1 set of each of the following each with the display
Arduino + Ramps1.4
MKS 32bit
Rumba

I wanted to learn about each of them so only 1 arduino and ramps.


#13

I did not manage to resolve the problem but ended up getting a new Mega2560 and ramps. This time it works.

All is working so far at this stage but still just testing all the other componets of the build.


#14

Did you check the voltage out of the Mega 5v regulator? Seem like it might have been this.


#15

So before I could even check, it blew. What I did was connect the laptop power supply to the round DC jack. The power supply is a 16v and assuming the board was the same as the others it should handle up to 35v. This was clearly not the case and the regulator blew. I replaced it with the new 1117 5v reg and now the when connecting the 2560 to the computer it wont even detect it via usb. For a $12 board what could i expect and now its not worth the time to troubleshoot it any further.

I replace it with a locally obtained mega2560 and knew I was on the right track when the arduino usb driver was detected and not some other generic usb driver I had to download for the other one to work.


#16

If you need to stack some more, here’s the $8 one

https://www.aliexpress.com/item/Mega-2560-R3-Mega2560-REV3-ATmega2560-16AU-CH340G-Board-ON-USB-Cable-Compatible-for-Arduino-Free/32579066323.html

Works great “most of the time”. I bet the regulator was dead already and it just blow itself up (and the board) with the 16v. Good to hear your got it working!