Z-axis sled raised before Z probe [Solved]


#1

Hi All,
I’m new to the community and Wilson designs. I recently completed printing and building a Wilson 2 with the sled Z probe and having issues that I have yet to resolve after hours of googling and reading over the Configuration.h file.

My issue is, that when auto-homing, I get Z-raise -> X-probe -> Y-probe -> Bed Center -> Raise Z offset -> X-Max (retracting sled) -> center bed -> Z-probe.

So probing Z, the sled has already been retracted.

Z_SAFE_HOMING and #define Z_PROBE_SLED enabled.

Don’t know where to look next to resolve the issue, so I appreciate any help.

Cheers
Dan


#2

I should also add, that if I manually deploy Z-probe, Z-probing will complete and sled raised as expected.


#3

Hi Dan,
Which firmware base are you using?


#4

mjrice,

First, thanks for your work on the project and the build videos. Very helpful and educational.

And for firmware, using Marlin 1.1.0-RCBugFix, commit 9b5515926a704bff1edb74772b0800cadf8c323d (latest).

Would you recommend RC8?

Thanks
Dan


#5

Problem Solved. Didn’t have the correct option #define Z_RACK_PINION in my Configuration.h file.

git clone https://github.com/mjrice/Marlin.git -> default branch RCBugFix didn’t contain the option. Only after switching branches to RCBugFix-mjrice did I see the Z_RACK_PINION option in Configuration_njrice.h. I had incorrectly assumed the Z_PROBE_SLED was used for rack and pinion.

After fixing my X_MIN_POS to 10 and X_MAX_POS to 196, everything worked great.